それマグで!

知識はカップより、マグでゆっくり頂きます。 takuya_1stのブログ

習慣に早くから配慮した者は、 おそらく人生の実りも大きい。

ubuntu11.04 でPT2が動かない.BCAS カードエラーでaribがErrorになった

pt1ドライバでrecpt1を動かしています.Ubuntuがアップデートしろとうるさい「やってやるよ。ドライバ再構築すれば良いんだろ?」と思ってやってみたら,地雷だった.

NTTカードリーダーのB-CASカードが読み込まれなくなった。ひどい


Ubuntuのアップデートはちゃんと出来た.PT1ドライバも入った.

なんと動かない.ドライバはmake && sudo make install で動くのに
原因はBCASカード
ccid の最新版でBCASが動かない.ひどい

ダウングレードする

ccid の 1.4系だとB-CASが認識されないらしいよ。なのでダウングレード用にパッケージを取得する

wget http://ftp.jaist.ac.jp/pub/Linux/ubuntu//pool/universe/p/pcsc-tools/pcsc-tools_1.4.16-1_amd64.deb
wget http://security.ubuntu.com/ubuntu/pool/universe/p/pcsc-lite/pcscd_1.5.5-3ubuntu2.1_amd64.deb
wget http://security.ubuntu.com/ubuntu/pool/main/p/pcsc-lite/libpcsclite-dev_1.5.5-3ubuntu2.1_amd64.deb
wget http://security.ubuntu.com/ubuntu/pool/main/p/pcsc-lite/libpcsclite1_1.5.5-3ubuntu2.1_amd64.deb
wget http://ftp.jaist.ac.jp/pub/Linux/ubuntu//pool/universe/c/ccid/libccid_1.3.11-1_amd64.deb

インストールする

ダウングレード用パッケージをインストール。

依存関係適当なので,同じコマンドを二回打ち込む

dpkg -i *.deb
#python-support のトリガを処理しています ...
(略
dpkg -i *.deb

依存関係を考慮せずにdebをブチ込むので、次の様なErrorになった。二回コマンド叩いたら入ったわ。

以下のパッケージの処理中にエラーが発生しました:
 libpcsclite-dev_1.5.5-3ubuntu2.1_amd64.deb

しっかし、Ubuntuのアップグレードは毎回毎回地雷だらけですね.まぁUbuntuだしそういうもんだろう.
今回はunityが使えるかと思ったらNX経由では全く動かなかった.すげー悲しい.

PT2をdvbで動かそうと思ったけど,B-CAS認識されない事件で時間食ったので諦めた

広告を非表示にする