それマグで!

知識はカップより、マグでゆっくり頂きます。 takuya_1stのブログ

習慣に早くから配慮した者は、 おそらく人生の実りも大きい。

debianでRubyGemsのアップデート に罠がある

ちゃんとやらないと、依存関係ではまります。要注意。

sudo aptitude install rubygems
sudo gem install rubygems-update -v '=1.3.1'
sudo /var/lib/gem/1.8/gem/bin/update_rubygems

rubygems-updateのバージョン指定

rubygems-updateをまず1.3.1にあげること。rubygems側で早く対応してほしい。

特にはまりどころがこれ

update_rubygems を実行すると、hoe の 2.3.0以上が必要だと怒られた。
で、hoe の 2.3.0 を gem で入れようとすると、gem の 1.3.1以上が必要だという。
現状のgemは1.2.0 ...

kurainの壺より

うまくいかない場合
いったんupdate_rubygemsを全部消しましょう。

sudo gem uninstall rubygems-update 

参考
http://d.hatena.ne.jp/r_kurain/20090725/1248523753

追記2010-01-07

この問題は、再発したので、ちゃんとした解決方法を考えた。

http://d.hatena.ne.jp/takuya_1st/20091215/1260875101

広告を非表示にする